Support Fonction ESTVIDE


La recopie d’une formule qui fait référence à une cellule vide provoque l’affichage d’un résultat nul (au mieux) ou l’apparition d’un message d’erreur. Or, la formule est JUSTE ! Pour éviter cet affichage, il est possible d'utiliser la fonction ESTVIDE

est vide support 01Dans la colonne C la formule est =B3/A3 en C3...

Dans la colonne D la formule est =SI(ESTVIDE(A3);"";B3/A3) en D3...

Il est possible de la résumer facilement par: SI la cellule est vide tu n'affiches rien, sinon tu fais la division pour faire apparaître le résultat en %.

Sur la dernière ligne vous remarquez l'erreur qui vient du fait qu'aucune valeur n'est saisie dans la colonne A et B. Dans l'avant dernière ligne un chiffre nul car la cellule A7 est saisie.

En utilisant cette formule vous aurez donc des tableaux propres et prêt à la saisie, sans besoin de manipuler les formules ultérieurement.