La fonction SI() permet d’afficher un résultat différent en fonction du contenu d’une autre cellule.


La syntaxe utilisée est la suivante :
=SI(condition à évaluer ; valeur de la cellule si la condition est vraie ; valeur si la condition est fausse)
Le résultat de la formule peut être une valeur numérique, une formule de calcul ou du texte.
Dans les conditions à évaluer vous pouvez utiliser les opérateurs suivants :

Egal =
Supérieur à >
Inférieur à <
Supérieur ou égal à >=
Inférieur ou égal à <=

Exemples :

1 – Si l’élève a 18 ans ou plus, alors il est majeur, sinon il est mineur.
La formule sera :
=SI(B1>=18;«majeur»;«mineur»)
B1 représente la cellule qui contient l’âge de l’élève.
Le texte se met entre guillemets
Que se passe-t-il si vous remplacez 19 par 17 ? par 18 ?

2 – Si le montant de la facture est supérieure à 200 €, alors vous avez une remise de 3% sur le montant de la facture, sinon vous n’avez pas de remise
La formule de calcul du montant de la remise sera :
=SI(B1>200;B1*3%;O)
B1 représente la cellule qui contient le montant de la facture.
Que se passe-t-il si vous remplacez 300 par 100 ? par 200 ?

SI imbriqués

On peut imbriquer jusqu’à sept fonctions SI() les unes dans les autres.

Exemple :

Calcul du prix d’entrée selon l’âge de la personne :
Age <= 8 ans 10€
Age entre 9 et 17 ans 15€
Age >= 18 ans 20€
La formule de calcul du prix sera la suivante :
=SI(B1<=8;10;SI(B1>=18;20;15))

 

Exercice-->


=ET() et =OU()

 La fonction =Si() peut être amélioré lorsqu'elle est utilisée avec d'autres fonctions telles que =ET() et =OU(). La partie qui suit démontre le fonctionnement de ces deux fonctions.

 

=ET(condition1;condition2;condition3 ...)
Il faut au moins deux conditions. Mais vous pouvez en ajouter d'autres.
Toutes les conditions doivent être remplies pour que la fonction affiche VRAI. Sinon, elle affichera FAUX.

Exercice-->

=OU(condition1;condition2; condition3 ...)
Il faut au moins deux conditions. Vous pouvez en ajouter d'autres.
L'une des conditions doit être remplie pour que la fonction affiche VRAI.
Si aucune des conditions n'est remplie, elle affichera FAUX.

Exercice-->

Copyright © 2015. All Rights Reserved.